Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issue with nActiveChannels in AI module
Hi Josh,

We are having the following issue with the AI module. We want to log data on 3 AI channels.

When we set nActiveChannels=3, data on channels 1 and 2 is logged fine, but data on channel 3 does not correspond to our signal. It is instead a sawtooth waveforem that looks like some sort of counter signal.

When we set nActiveChannels=5, data on channels 1, 2 and 3 is logged fine. However, the counter-like signal then appears on channels 4 and 5.

When we set nActiveChannels=8, data on all channels is logged fine.

We can work with this by setting nActiveChannels=5 but it is not optimal in terms of speed and memory since we only need 3 channels.

I attached below a figure of the logged data waveforms illustrating this issue.

Any ideas?


[Image: view?usp=sharing]
Hi PrsaLab,

I'm not sure what to make of this phantom sawtooth.
I'll try to replicate the issue.
What instruments do you have connected to Ch1, 2 and 3?

Hi Josh,

Thanks for you prompt reply. The instruments connected to the 3 channels are:

- Ch. 1 and 2: angular position of dc motor (analog output from a quadrature decoder to analog converter).
- Ch. 3: Wire1Out from Bpod.
Hi PrsaLab,

Another user wrote in with the issue, and I think we have a solution here.

Please try it and let us know if it works for you.

Hi Josh,

We uploaded the new firmware and the phantom sawtooth is gone. We can now set nActiveChannels to 3 without any issues.

Forum Jump: