Bpod v2.3 ports half working

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bpod v2.3 ports half working
#1
Josh (or anyone who may know),

Just tried building the new v2.3 Bpod (hold up in a my garage trying to keep busy as Princeton is now shut down).  Everything seemed good except when I connect a nose port to jacks 1 and 4. Poke in events are not detected (other port functions, LED, water valve work fine in all jacks) and poke in events are detected if I connect the same nose port to jacks 2 and 3.  I've been trying to hunt around on the board for a short (seeedstudio did once send us a circuit board that was wired incorrectly with a hidden short in one of the layers) but so far can't seem to find anything.  The voltage input to IC12 seems off for those 2 jacks so I think IC12 is functioning fine, it's just getting a bad input and passing that along.  When I test the pins on the ethernet port on the Bpod board with a nose port connected everything looks identical between a functioning jack (2 or 3) and the non-functioning jacks (1 and 4).  Finally I measured the voltage across the phototransistor on the nose port itself.  When connected to a functioning jack I see a voltage of 0.15V when poked out and 4.55V when poked in.  However, when I connect the same nose port to a non-functioning jack I see a voltage of 0.15V when poked out but only 0.65V when poked in.  I get the same result after removing the new 22k pull-up resistors.  If I measure the voltage across the pads for the new pull-up resistors I get a similar behavior.  Functioning jack, poke out 4.85V, poke in 0.15V.  Non-functioning jack, poke out 4.85V, poke in 4.15V.  Any thoughts on what could be causing this? Any other tests I should run to try to find the source of the problem (teensy?, IC12?, PCB?)

Thanks
Chuck
Reply
#2
After hunting around on the board I discovered that some flux residue lying between the feet of IC12 connected them electrically with very high resistance (in the 10s to 100s of kOhms).  After carefully cleaning this the resistance between neighboring pins on IC12 went to Infinity and the behavior of all the nose ports returned to normal. I will note this was a board I made myself (never had any such problems with boards ordered from Sanworks).
Reply
#3
Hi Chuck,

Thanks for sharing the solution!

-Josh
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)