Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pulse Pal only recognized as Bossa port, connection fails
I am trying to use Pulse Pal 2 with a windows system. When I first connected the USB cable to my PC, the Pulse Pal's display lit up, it was recognized as Arduino Due and I was able to follow the online tutorial to display the firmware version via Python. So far, so good. I then decided to switch to a Matlab interface because I did not want to have to switch between Python 3 and Python 2.7 all the time. However, with Matlab I was not able to establish serial communication with the Pulse Pal at all. At some point while I worked on the basic connection (never getting to the point of actually loading anything onto it), the Pulse Pal's display went black. It has not lit up ever since and I have not been able to establish serial communication. Now, it is recognized as a Bossa port, not an Arduino due, and every time I run the Python code that used to work, I get the following error message:

 File "C:/Users/PycharmProjects/PulsePal/", line 6, in <module>
    myPulsePal.connect('COM11') # Connect to PulsePal on port COM4 (open port, handshake and receive firmware version)
  File "C:\Users\PycharmProjects\PulsePal\", line 64, in connect
    self.firmwareVersion = struct.unpack('<I',fvBytes)[0]
struct.error: unpack requires a string argument of length 4

For reference, this is the tutorial code I am running:

from PulsePal import PulsePalObject # Import PulsePalObject
import serial

myPulsePal = PulsePalObject() 

I have tried different PCs and also uninstalling and reinstalling the driver. No change.

I do not think the Pulse Pal is completely broken because the blue lights at trigger and output channels still go off, but the display is dead and I cannot connect to it anymore. 

I would appreciate thoughts on this problem.

If the device is persistently recognized as a Bossa port, I suspect that it is in bootloader mode, awaiting firmware (though the channel LEDs shouldn't react in that case). I'm not sure why it would have lost or corrupted its firmware, but this has happened once or twice in our experience with Bpod r1 - and re-loading the firmware fixed the issue.

To load the firmware to the device, download the firmware file from here and follow the instructions here. It is possible that you'll need to use Arduino Due's 'programming' USB port to rescue the board (which is inconveniently blocked by the Pulse Pal device enclosure).

If you purchased the Pulse Pal from us and you'd rather not tinker with it yourself, please send your shipping address to and we'll take it in for repair.

Hi Josh,

I loaded the firmware and now everything works perfectly again! Thank you so much!

Forum Jump: