Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
bpod not lighting on
Hi josh

any idea of why the bpod would  stop working after uploading firmware? 
this is what i did:
- bpod is connected, matlab installed, state machine (r2) firmware uploaded, and tried running a valve through one of the ports and it works
- not i tried uploading the rotary encoder module firmware, while the bpod was connected. I think i messed it up as i am not sure if the rotary encoder firmware should be uploaded to the state machine. 

Now the bpod is not even lighting on when powered. Is there a way to reset it? 

Hi Sandra,

The rotary encoder firmware must be uploaded to the rotary encoder module, not the state machine. 
Make sure you select the rotary encoder module's COM port in the Arduino application when uploading the firmware.
In older versions of Arduino / Teensyduino, there was a bug that would sometimes load the firmware to the incorrect device, even if the correct COM port was selected. If you suspect that this is happening, unplug the other Bpod devices from the PC and load to the target device.

To fix the state machine you have, upload state machine firmware to the state machine.

I hope this helps!

Forum Jump: