Bpod devices not found

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bpod devices not found
#1
I just successfully completed the installation of the Bpod software from the repository https://github.com/sanworks/Bpod_Gen2 on my computer (we're using Bpod 0.7 on windows 10). However when I plug the Bpod devices and try to run it, it says "Bpod device not found". I've tried it with two different devices and none of them work.
The error I get is: 

'Error using BpodObject/Connect2BpodSM (line 106)
   
    Error: Could not find Bpod device.
    Tried USB serial port(s): COM3
    Try calling Bpod with a serial port argument, i.e. Bpod('COM3')'

Error: Bpod device not found.

The device manager on my computer shows a 'USB serial device (COM3)' under Ports, so I tried Bpod('COM3') but it just gives a different error which says the serial port is returning 0 bytes.
Does anybody have an idea of how to fix this?

Thank you!
Reply
#2
Hi Veronica,

If you power-cycle the state machine (unplug the USB cable and re-plug it), restart MATLAB and try Bpod('COM3') again, does it work?

-Josh
Reply
#3
Hi Josh,

No, it does not work.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)