Hardware software compatibility

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hardware software compatibility
#1
Dear all

I have two Bpod .5 which have been running for a while very well. Now I want to start using a Bpod .8 and a Bpod r2 that I have. The old software that I have been using apparently doesn't work with the new hardware. So to be more specific right now with Bpod .8 in the initializeHardware.m* when:


Code:
TestPort = IOPort('OpenSerialPort', PortString, 'BaudRate=115200, OutputBufferSize=8000, DTR=1');

IOPort('Write', TestPort, char(54), 1);
Byte = IOPort('Read', TestPort, 1, 1);
The port opens successfully and it can also write to the port. But when it gets to read, it reads "222". Usually if I run the read command (even before writing) few hundred times it gives 222 continuously until it spits out 53 which is the proper response the code is waiting for. However even when this stage is passes I face other errors within the protocol with runStateMatrix. I guess this is mostly due incompatibility.

So is there a document about different versions/releases of hardware and the matching software?
For example which firmware should I load on my Bpod .8 (or r2) and which Bpod software works with them?

Best thanks

* https://github.com/KepecsLab/Bpod_r0_5/b...Hardware.m
Reply
#2
Hi Mahyar,

With Bpod r0.7 or newer, you'll need the software from our repository:

https://github.com/sanworks/Bpod_Gen2

-Josh
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)