Valve crash

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Valve crash
#1
Hi all
I am using Bpod r.5. It has been working for almost (or even more than) a year now. I have had valves which stopped working and I replaced them. But yesterday it happened several times that the system stopped working at a "reward state". I noticed that this happens stochastic and when it happens there comes a relatively big portion of water out of the spout and the Bpod is not sending any more of state updates to the governing machine.
I am using a linux os and use octave to run Bpod: https://github.com/moonfriend/Bpod_cli.git


Then I reinstalled the firmware. It worked for a while but it happened again.
Then I tested the Bpod Matlab interface trying to get out some water out of the spouts. And it got stuck several times but this time the valves stayed open and the water kept running while the Bpod interface froze and gave an error. (I'll send the error as soon as I go the setup). This happened again for all the three ports in short time afterward.
I opened all the cables and valves and reconnected them and then ran some calibration and it worked so far. Though I am afraid it might stop again in the middle of the experiments.

Do you have any idea why it happened? Should I provide extra power input? (currently I am only powering the device up with the usb).

I would appreciate to hear any comments and ideas on this.
Thanks
Reply
#2
update:

Unfortunately I don't have access to the log anymore. 
I re-calibrated the valves again. And until now more than 400 reward bouts (i.e. opening and closing of the valves) it is working without a problem. The times for my small amounts of water (10 micro.L) had drifted a lot (probably due to minerals in the water). Could this be due to the vavleTime being smaller compared to the actual mechanical ability of the valve for opening and closing? {I am just gussing}
Reply
#3
Hi Mahyar,

If you're using the Lee valves we carry, the time to full-open should be 3ms, as per manufacturer specs (and 2ms if gating air).
Solenoid pinch valves like this one take ~30-40ms to fully open, so the calibration curve can be non-linear.

As a sanity check, I'd print out the valve times that are being generated by the GetValveTimes() function. If your script is requesting liquid amounts beyond the limits of the calibration curve, it can result in unexpectedly long valve-open times.

Generally, I'd try using a 12V DC wall adapter (1.5A, positive-center), especially if you have other power-hungry devices on the USB hub.

I don't have experience running Bpod in Octave - do you see the same issue with our MATLAB software + the latest firmware?

-Josh
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)