Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pulsepal went dark after computer restart
#1
Hi Josh and others,

PulsePal v2 was plugged into the serial port while the computer restarted. After reboot, there is no display, LEDs are not lighting up, and MATLAB can no longer recognize.
When I tried re-uploading the Arduino firmware, the LEDs flashed on briefly and Arduino says CPU reset was successful. However it still does not display or connect to MATLAB.

Could something have been corrupted during the computer restart? Or driver issue? Not sure whether it is PulsePal hardware issue or computer issue.
Thanks,

-Jason
Reply
#2
Hi Jason,

If you look at the console output in the Arduino application (above the 'CPU Reset successful' message), are there any compile errors?
Please keep in mind that Pulse Pal requires version 1 of the SDFat library, available here.
Does Pulse Pal show as 'Arduino Due (Native USB Port)' in the Device manager (if using Windows)?
If so, try connecting with a COM port argument, e.g.

PulsePal('COM3')

-Josh
Reply
#3
Thanks for the response Josh!

There are no compile errors in Arduino. SDFat-1.1.4 is in the right folder.
Yes, it shows up as Arduino Due (native) in device manager.

I repeated the firmware update process, and LEDs lit up during that, but afterwards everything is still dark. PulsePal('COM5') results in Error: Could not find your Pulse Pal device.
Reply
#4
Hi Jason,

I'm not sure what to make of it.
Could be the screen or the Arduino board.
If you purchased it recently from our assembly service, please follow up with support@sanworks.io for a replacement unit.

Thanks,
-Josh
Reply


Forum Jump: