Pulse Pal Hardware installation

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pulse Pal Hardware installation
#3
(02-16-2018, 11:26 PM)Josh Wrote: Hi Dymphie,


The latest drivers are contained in the Arduino software package - so you definitely have them if you installed Arduino.

If you're not seeing anything appear / disappear from the device manager, and Pulse Pal is on (powered) and responds to the thumb joystick, my first suspicion is the USB cable. If you try a different USB micro cable, does it work?

-Josh

Hi,
so I replaced the USB cable and I believe the Com port is 8. Then I try to continue with the upgrade of the firmware by selecting this port and clicking on the upload button. I obtain the following error message (sorry for the length):

Arduino: 1.8.5 (Windows XP), Board: "Arduino Due (Native USB Port)"


E:\User Data\Administrator\My Documents\arduino-1.8.5\arduino-builder -dump-prefs -logger=machine -hardware E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware -hardware E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\tools-builder -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware\tools\avr -tools E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -built-in-libraries E:\User Data\Administrator\My Documents\arduino-1.8.5\libraries -libraries E:\User Data\Administrator\My Documents\Arduino\libraries -fqbn=arduinoConfusedam:arduino_due_x -ide-version=10805 -build-path E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753 -warnings=none -build-cache E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_cache_543288 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.bossac.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\bossac\1.6.1-arduino -verbose E:\User Data\Administrator\My Documents\PulsePal\Firmware\PulsePal_2_0_0\PulsePal_2_0_0.ino
E:\User Data\Administrator\My Documents\arduino-1.8.5\arduino-builder -compile -logger=machine -hardware E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware -hardware E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\tools-builder -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware\tools\avr -tools E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -built-in-libraries E:\User Data\Administrator\My Documents\arduino-1.8.5\libraries -libraries E:\User Data\Administrator\My Documents\Arduino\libraries -fqbn=arduinoConfusedam:arduino_due_x -ide-version=10805 -build-path E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753 -warnings=none -build-cache E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_cache_543288 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.bossac.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\bossac\1.6.1-arduino -verbose E:\User Data\Administrator\My Documents\PulsePal\Firmware\PulsePal_2_0_0\PulsePal_2_0_0.ino
Using board 'arduino_due_x' from platform in folder: E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11
Using core 'arduino' from platform in folder: E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11
Detecting libraries used...
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "nul"
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "-IE:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal\src" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "nul"
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "-IE:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal\src" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\libraries\SPI\src" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "nul"
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "-IE:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal\src" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\libraries\SPI\src" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\preproc\ctags_target_for_gcc_minus_e.cpp"
E:\User Data\Administrator\My Documents\PulsePal\Firmware\PulsePal_2_0_0\PulsePal_2_0_0.ino:43:19: fatal error: SdFat.h: No such file or directory

 #include <SdFat.h>

                   ^

compilation terminated.

Using library LiquidCrystal at version 1.0.7 in folder: E:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal
Using library SPI at version 1.0 in folder: E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\libraries\SPI
exit status 1
Error compiling for board Arduino Due (Native USB Port).


Is there anything that you can tell me that this error message might want? I read in another forum answer that this might require me to download and install Psychtoolbox by-passing any possible Java problem, is that true? In my case this would require me to install a 64-bit version of Matlab which I'm not sure this rather old desktop can even do.
Please let me know what I should do.

Thanks a bunch,
Dymphie Suchanek

(02-16-2018, 11:59 PM)dsuchan Wrote:
(02-16-2018, 11:26 PM)Josh Wrote: Hi Dymphie,


The latest drivers are contained in the Arduino software package - so you definitely have them if you installed Arduino.

If you're not seeing anything appear / disappear from the device manager, and Pulse Pal is on (powered) and responds to the thumb joystick, my first suspicion is the USB cable. If you try a different USB micro cable, does it work?

-Josh

Hi,
so I replaced the USB cable and I believe the Com port is 8. Then I try to continue with the upgrade of the firmware by selecting this port and clicking on the upload button. I obtain the following error message (sorry for the length):

Arduino: 1.8.5 (Windows XP), Board: "Arduino Due (Native USB Port)"


E:\User Data\Administrator\My Documents\arduino-1.8.5\arduino-builder -dump-prefs -logger=machine -hardware E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware -hardware E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\tools-builder -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware\tools\avr -tools E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -built-in-libraries E:\User Data\Administrator\My Documents\arduino-1.8.5\libraries -libraries E:\User Data\Administrator\My Documents\Arduino\libraries -fqbn=arduinoConfusedam:arduino_due_x -ide-version=10805 -build-path E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753 -warnings=none -build-cache E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_cache_543288 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.bossac.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\bossac\1.6.1-arduino -verbose E:\User Data\Administrator\My Documents\PulsePal\Firmware\PulsePal_2_0_0\PulsePal_2_0_0.ino
E:\User Data\Administrator\My Documents\arduino-1.8.5\arduino-builder -compile -logger=machine -hardware E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware -hardware E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\tools-builder -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware\tools\avr -tools E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -built-in-libraries E:\User Data\Administrator\My Documents\arduino-1.8.5\libraries -libraries E:\User Data\Administrator\My Documents\Arduino\libraries -fqbn=arduinoConfusedam:arduino_due_x -ide-version=10805 -build-path E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753 -warnings=none -build-cache E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_cache_543288 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.bossac.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\bossac\1.6.1-arduino -verbose E:\User Data\Administrator\My Documents\PulsePal\Firmware\PulsePal_2_0_0\PulsePal_2_0_0.ino
Using board 'arduino_due_x' from platform in folder: E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11
Using core 'arduino' from platform in folder: E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11
Detecting libraries used...
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "nul"
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "-IE:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal\src" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "nul"
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "-IE:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal\src" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\libraries\SPI\src" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "nul"
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "-IE:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal\src" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\libraries\SPI\src" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\preproc\ctags_target_for_gcc_minus_e.cpp"
E:\User Data\Administrator\My Documents\PulsePal\Firmware\PulsePal_2_0_0\PulsePal_2_0_0.ino:43:19: fatal error: SdFat.h: No such file or directory

 #include <SdFat.h>

                   ^

compilation terminated.

Using library LiquidCrystal at version 1.0.7 in folder: E:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal
Using library SPI at version 1.0 in folder: E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\libraries\SPI
exit status 1
Error compiling for board Arduino Due (Native USB Port).


Is there anything that you can tell me that this error message might want? I read in another forum answer that this might require me to download and install Psychtoolbox by-passing any possible Java problem, is that true? In my case this would require me to install a 64-bit version of Matlab which I'm not sure this rather old desktop can even do.
Please let me know what I should do.

Thanks a bunch,
Dymphie Suchanek
Hi,
sorry to respond to my own question, but I downloaded the SdFat library and moved this folder into the Arduino libraries. Now the problem still seems to be the port. It almost uploads completely but then the error says that "No device found on COM8". Maybe the computer is too old, no idea.
Now I'm really not sure what the problem might be.

Any advice?

Regards,

Dymphie Suchanek
Reply


Messages In This Thread
Pulse Pal Hardware installation - by dsuchan - 02-16-2018, 07:36 PM
RE: Pulse Pal Hardware installation - by Josh - 02-16-2018, 11:26 PM
RE: Pulse Pal Hardware installation - by dsuchan - 02-16-2018, 11:59 PM
RE: Pulse Pal Hardware installation - by Josh - 02-17-2018, 07:11 PM
RE: Pulse Pal Hardware installation - by dsuchan - 02-19-2018, 04:37 PM
RE: Pulse Pal Hardware installation - by Josh - 02-19-2018, 07:59 PM
RE: Pulse Pal Hardware installation - by dsuchan - 02-19-2018, 09:11 PM
RE: Pulse Pal Hardware installation - by Josh - 02-21-2018, 03:01 AM
RE: Pulse Pal Hardware installation - by dsuchan - 02-21-2018, 04:35 PM
RE: Pulse Pal Hardware installation - by dsuchan - 02-21-2018, 06:27 PM
RE: Pulse Pal Hardware installation - by Josh - 02-21-2018, 08:25 PM

Forum Jump: