Pulse Pal Hardware installation

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pulse Pal Hardware installation
#1
Hi,
I received my Pulse Pal v. 2 yesterday and wanted to install it today. I followed the Sanworks link to the Pulse Pal WIKI and started with the installation of the Pulse Pal on my Windows XP desktop. I was not sure on whether to already connect the device vis USB to the computer but I decided to anyway. I downloaded the repository and placed it into the appropriate location on the computer. 
I know I need the drivers to be able to run Pulse Pal but I'm not quite sure how to install these from the downloaded repository so instead I thought it best to upgrade the firmware, which most likely also contains the appropriate drivers. I thus downloaded Arduino and followed the instructions on that WIKI page. Problem arose with determining the Com port. As the USB connection should create a virtual Com port I checked the system/Device manager settings for the ports but it does not seem to be present. When I remove the USB from the computer all are still present, none disappear when I disconnect. I did try other USB port, both in front as well as in back but nothing changes.
I'm sorry this is such a simple question but I'm simply stuck at this point and I wish I could continue and finally use the Pulse Pal. Sad

Any advice would be greatly appreciated,

Dymphie Suchanek
Reply
#2
Hi Dymphie,


The latest drivers are contained in the Arduino software package - so you definitely have them if you installed Arduino.

If you're not seeing anything appear / disappear from the device manager, and Pulse Pal is on (powered) and responds to the thumb joystick, my first suspicion is the USB cable. If you try a different USB micro cable, does it work?

-Josh
Reply
#3
(02-16-2018, 11:26 PM)Josh Wrote: Hi Dymphie,


The latest drivers are contained in the Arduino software package - so you definitely have them if you installed Arduino.

If you're not seeing anything appear / disappear from the device manager, and Pulse Pal is on (powered) and responds to the thumb joystick, my first suspicion is the USB cable. If you try a different USB micro cable, does it work?

-Josh

Hi,
so I replaced the USB cable and I believe the Com port is 8. Then I try to continue with the upgrade of the firmware by selecting this port and clicking on the upload button. I obtain the following error message (sorry for the length):

Arduino: 1.8.5 (Windows XP), Board: "Arduino Due (Native USB Port)"


E:\User Data\Administrator\My Documents\arduino-1.8.5\arduino-builder -dump-prefs -logger=machine -hardware E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware -hardware E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\tools-builder -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware\tools\avr -tools E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -built-in-libraries E:\User Data\Administrator\My Documents\arduino-1.8.5\libraries -libraries E:\User Data\Administrator\My Documents\Arduino\libraries -fqbn=arduinoConfusedam:arduino_due_x -ide-version=10805 -build-path E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753 -warnings=none -build-cache E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_cache_543288 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.bossac.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\bossac\1.6.1-arduino -verbose E:\User Data\Administrator\My Documents\PulsePal\Firmware\PulsePal_2_0_0\PulsePal_2_0_0.ino
E:\User Data\Administrator\My Documents\arduino-1.8.5\arduino-builder -compile -logger=machine -hardware E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware -hardware E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\tools-builder -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware\tools\avr -tools E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -built-in-libraries E:\User Data\Administrator\My Documents\arduino-1.8.5\libraries -libraries E:\User Data\Administrator\My Documents\Arduino\libraries -fqbn=arduinoConfusedam:arduino_due_x -ide-version=10805 -build-path E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753 -warnings=none -build-cache E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_cache_543288 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.bossac.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\bossac\1.6.1-arduino -verbose E:\User Data\Administrator\My Documents\PulsePal\Firmware\PulsePal_2_0_0\PulsePal_2_0_0.ino
Using board 'arduino_due_x' from platform in folder: E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11
Using core 'arduino' from platform in folder: E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11
Detecting libraries used...
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "nul"
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "-IE:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal\src" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "nul"
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "-IE:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal\src" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\libraries\SPI\src" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "nul"
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "-IE:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal\src" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\libraries\SPI\src" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\preproc\ctags_target_for_gcc_minus_e.cpp"
E:\User Data\Administrator\My Documents\PulsePal\Firmware\PulsePal_2_0_0\PulsePal_2_0_0.ino:43:19: fatal error: SdFat.h: No such file or directory

 #include <SdFat.h>

                   ^

compilation terminated.

Using library LiquidCrystal at version 1.0.7 in folder: E:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal
Using library SPI at version 1.0 in folder: E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\libraries\SPI
exit status 1
Error compiling for board Arduino Due (Native USB Port).


Is there anything that you can tell me that this error message might want? I read in another forum answer that this might require me to download and install Psychtoolbox by-passing any possible Java problem, is that true? In my case this would require me to install a 64-bit version of Matlab which I'm not sure this rather old desktop can even do.
Please let me know what I should do.

Thanks a bunch,
Dymphie Suchanek

(02-16-2018, 11:59 PM)dsuchan Wrote:
(02-16-2018, 11:26 PM)Josh Wrote: Hi Dymphie,


The latest drivers are contained in the Arduino software package - so you definitely have them if you installed Arduino.

If you're not seeing anything appear / disappear from the device manager, and Pulse Pal is on (powered) and responds to the thumb joystick, my first suspicion is the USB cable. If you try a different USB micro cable, does it work?

-Josh

Hi,
so I replaced the USB cable and I believe the Com port is 8. Then I try to continue with the upgrade of the firmware by selecting this port and clicking on the upload button. I obtain the following error message (sorry for the length):

Arduino: 1.8.5 (Windows XP), Board: "Arduino Due (Native USB Port)"


E:\User Data\Administrator\My Documents\arduino-1.8.5\arduino-builder -dump-prefs -logger=machine -hardware E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware -hardware E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\tools-builder -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware\tools\avr -tools E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -built-in-libraries E:\User Data\Administrator\My Documents\arduino-1.8.5\libraries -libraries E:\User Data\Administrator\My Documents\Arduino\libraries -fqbn=arduinoConfusedam:arduino_due_x -ide-version=10805 -build-path E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753 -warnings=none -build-cache E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_cache_543288 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.bossac.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\bossac\1.6.1-arduino -verbose E:\User Data\Administrator\My Documents\PulsePal\Firmware\PulsePal_2_0_0\PulsePal_2_0_0.ino
E:\User Data\Administrator\My Documents\arduino-1.8.5\arduino-builder -compile -logger=machine -hardware E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware -hardware E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\tools-builder -tools E:\User Data\Administrator\My Documents\arduino-1.8.5\hardware\tools\avr -tools E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages -built-in-libraries E:\User Data\Administrator\My Documents\arduino-1.8.5\libraries -libraries E:\User Data\Administrator\My Documents\Arduino\libraries -fqbn=arduinoConfusedam:arduino_due_x -ide-version=10805 -build-path E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753 -warnings=none -build-cache E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_cache_543288 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.bossac.path=E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\bossac\1.6.1-arduino -verbose E:\User Data\Administrator\My Documents\PulsePal\Firmware\PulsePal_2_0_0\PulsePal_2_0_0.ino
Using board 'arduino_due_x' from platform in folder: E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11
Using core 'arduino' from platform in folder: E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11
Detecting libraries used...
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "nul"
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "-IE:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal\src" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "nul"
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "-IE:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal\src" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\libraries\SPI\src" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "nul"
"E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf  -w -x c++ -E -CC -mcpu=cortex-m3 -mthumb -DF_CPU=84000000L -DARDUINO=10805 -DARDUINO_SAM_DUE -DARDUINO_ARCH_SAM  -D__SAM3X8E__ -mthumb -DUSB_VID=0x2341 -DUSB_PID=0x003e -DUSBCON '-DUSB_MANUFACTURER="Arduino LLC"' '-DUSB_PRODUCT="Arduino Due"' "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/libsam" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/CMSIS/Include/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\system/CMSIS/Device/ATMEL/" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\cores\arduino" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\variants\arduino_due_x" "-IE:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal\src" "-IE:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\libraries\SPI\src" "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\sketch\PulsePal_2_0_0.ino.cpp" -o "E:\USERDA~1\ADMINI~1\LOCALS~1\Temp\arduino_build_260753\preproc\ctags_target_for_gcc_minus_e.cpp"
E:\User Data\Administrator\My Documents\PulsePal\Firmware\PulsePal_2_0_0\PulsePal_2_0_0.ino:43:19: fatal error: SdFat.h: No such file or directory

 #include <SdFat.h>

                   ^

compilation terminated.

Using library LiquidCrystal at version 1.0.7 in folder: E:\User Data\Administrator\My Documents\arduino-1.8.5\libraries\LiquidCrystal
Using library SPI at version 1.0 in folder: E:\User Data\Administrator\Local Settings\Application Data\Arduino15\packages\arduino\hardware\sam\1.6.11\libraries\SPI
exit status 1
Error compiling for board Arduino Due (Native USB Port).


Is there anything that you can tell me that this error message might want? I read in another forum answer that this might require me to download and install Psychtoolbox by-passing any possible Java problem, is that true? In my case this would require me to install a 64-bit version of Matlab which I'm not sure this rather old desktop can even do.
Please let me know what I should do.

Thanks a bunch,
Dymphie Suchanek
Hi,
sorry to respond to my own question, but I downloaded the SdFat library and moved this folder into the Arduino libraries. Now the problem still seems to be the port. It almost uploads completely but then the error says that "No device found on COM8". Maybe the computer is too old, no idea.
Now I'm really not sure what the problem might be.

Any advice?

Regards,

Dymphie Suchanek
Reply
#4
Hi Dymphie,

It sounds like you're trying to get Pulse Pal talking to MATLAB - you shouldn't need to update the firmware to do this.
However, since Arduino can't see the board, I'm worried that your drivers didn't correctly install.
From the device manager, do you see a "Serial Ports" category? If so, could you please share the list of devices you find there? 
Also please list any "unknown devices" (I think in XP they're displayed with a yellow triangle)

Thanks
-Josh
Reply
#5
(02-17-2018, 07:11 PM)Josh Wrote: Hi Dymphie,

It sounds like you're trying to get Pulse Pal talking to MATLAB - you shouldn't need to update the firmware to do this.
However, since Arduino can't see the board, I'm worried that your drivers didn't correctly install.
From the device manager, do you see a "Serial Ports" category? If so, could you please share the list of devices you find there? 
Also please list any "unknown devices" (I think in XP they're displayed with a yellow triangle)

Thanks
-Josh

Hi,
since I need the Pulse Pal to generate a ramp and hold pulse, I was told by a colleague of yours that I could do this easily in Matlab, so yes I'm trying to get the Pulse Pal to communicate with Matlab. Th attached JPEG was taken after I had tried to uninstall the USB controllers, performed a restart and allowed the computer to re-install the devices. Then I attached the Pulse Pal into one of the free USB ports and checked the Device manager. When I right-click on the "Ports" and tell him to scan for new hardware, a balloon shows up in the bottom right-hand corner stating that "Found New Hardware. A problem occurred during hardware installation. Your new hardware might not work properly". And by the way, there are no "unknown devices" listed.

Hope this information is sufficient.

Greetings,
Dymphie


Attached Files Thumbnail(s)
   
Reply
#6
Hi Dymphie,

In the "Ports (COM & LPT)" menu, "COM8" is listed as a "Communications Port".
I suspect that this is Pulse Pal, and that XP is using an incorrect driver.
If you unplug Pulse Pal, does "COM8" disappear from the menu?
If so, plug Pulse Pal back in, right-click "COM8" and select "Update Driver Software". When prompted, navigate to the "Drivers" folder in the Pulse Pal repository:

/Pulse Pal/Drivers/  

Windows should automatically detect the correct driver file and install it.
If this doesn't happen, right-click "COM8" and select "uninstall". Then, unplug and re-plug Pulse Pal. This should cause Windows to run "Adding new hardware", and prompt you for the path to the drivers.

I hope this helps!

Josh
Reply
#7
(02-19-2018, 07:59 PM)Josh Wrote: Hi Dymphie,

In the "Ports (COM & LPT)" menu, "COM8" is listed as a "Communications Port".
I suspect that this is Pulse Pal, and that XP is using an incorrect driver.
If you unplug Pulse Pal, does "COM8" disappear from the menu?
If so, plug Pulse Pal back in, right-click "COM8" and select "Update Driver Software". When prompted, navigate to the "Drivers" folder in the Pulse Pal repository:

/Pulse Pal/Drivers/  

Windows should automatically detect the correct driver file and install it.
If this doesn't happen, right-click "COM8" and select "uninstall". Then, unplug and re-plug Pulse Pal. This should cause Windows to run "Adding new hardware", and prompt you for the path to the drivers.

I hope this helps!

Josh

Sorry to say but this does not help much. You were right in that the "COM8" was the Pulse Pal. But unplugging the device did not lead to its disappearance. So I uninstalled it. Plugging it back in caused it to be named "COM1" now. I right-clicked on the "COM1" and went to Properties and "Update Drivers". You can't simply go as far as /Pulse Pal/Drivers/ because then you have a further choice namely between Pulse Pal 1_X and Pulse Pal 2_X  of which I took the latter. It searches for a bit and then the window shown in the attachment appeared. I also tried the Pulse Pal 1_X where the choices are maple-dfu, maple-serial but same thing happens. As this is the new repository I also extracted the old from github and tried those Drivers but it does not work either.

I would try another computer but unfortunately that does not have Matlab installed and it does not have any internet access.

Hope you have another idea.

Dymphie


Attached Files Thumbnail(s)
   
Reply
#8
Hi Dymphie

You have Pulse Pal 2, so Pulse Pal 2_X  is the correct folder. It's unusual that the port did not disappear from the device manager when you unplugged it. I'm not sure what to make of that.  

It sounds like Windows XP has a driver already installed that it thinks is compatible with Pulse Pal, but actually isn't. If you right-click the device in the device manager, select "properties" and then the "driver" tab and the "driver details" button, you can see details about the driver file Windows is using. Could you please post the vendor and the path to the driver file you find there?

One option is to completely uninstall the device and move the incorrect driver file out of the C:/windows/system32/ directory. This will force Windows to try the Arduino driver, because it won't have a "better" one available. There is some risk to this - other instruments may depend on the existing driver, so remember to move the existing driver back to /system32/ when you're done.
Another option is to try the latest driver from Arduino. You can download it here (choose "zip for non-admin install"), extract the .zip and the drivers are in /arduino-x.y.z/drivers. Perhaps Windows XP will recognize the latest one as a "better" driver than the one you have.

-Josh
Reply
#9
(02-21-2018, 03:01 AM)Josh Wrote: Hi Dymphie

You have Pulse Pal 2, so Pulse Pal 2_X  is the correct folder. It's unusual that the port did not disappear from the device manager when you unplugged it. I'm not sure what to make of that.  

It sounds like Windows XP has a driver already installed that it thinks is compatible with Pulse Pal, but actually isn't. If you right-click the device in the device manager, select "properties" and then the "driver" tab and the "driver details" button, you can see details about the driver file Windows is using. Could you please post the vendor and the path to the driver file you find there?

One option is to completely uninstall the device and move the incorrect driver file out of the C:/windows/system32/ directory. This will force Windows to try the Arduino driver, because it won't have a "better" one available. There is some risk to this - other instruments may depend on the existing driver, so remember to move the existing driver back to /system32/ when you're done.
Another option is to try the latest driver from Arduino. You can download it here (choose "zip for non-admin install"), extract the .zip and the drivers are in /arduino-x.y.z/drivers. Perhaps Windows XP will recognize the latest one as a "better" driver than the one you have.

-Josh
Hi,
so the Driver details are as follows:

C:\WINDOWS.1\system32\DRIVERS\serenum.sys
C:\WINDOWS.1\system32\DRIVERS\serial.sys

If I look for these files I can find them but not under system32\DRIVERS there is no ""DRIVERS only "drivers". If I try to move these two files to the desktop and delete them in the original folder, they immediately reappear. I know that sounds strange but it is so.

Different question, even though this Windows XP computer has the microscope controls on them and I did want to use only a single computer for my intrinsic imaging, will the Pulse Pal work on a Windows 8 labtop? On the WIKI Pulse Pal is mentioned only up to Win7? I have already spent too much time on this and if its the old computer that is not functioning properly I do not want to waste more time on this.

Dymphie
Reply
#10
(02-21-2018, 04:35 PM)dsuchan Wrote:
(02-21-2018, 03:01 AM)Josh Wrote: Hi Dymphie

You have Pulse Pal 2, so Pulse Pal 2_X  is the correct folder. It's unusual that the port did not disappear from the device manager when you unplugged it. I'm not sure what to make of that.  

It sounds like Windows XP has a driver already installed that it thinks is compatible with Pulse Pal, but actually isn't. If you right-click the device in the device manager, select "properties" and then the "driver" tab and the "driver details" button, you can see details about the driver file Windows is using. Could you please post the vendor and the path to the driver file you find there?

One option is to completely uninstall the device and move the incorrect driver file out of the C:/windows/system32/ directory. This will force Windows to try the Arduino driver, because it won't have a "better" one available. There is some risk to this - other instruments may depend on the existing driver, so remember to move the existing driver back to /system32/ when you're done.
Another option is to try the latest driver from Arduino. You can download it here (choose "zip for non-admin install"), extract the .zip and the drivers are in /arduino-x.y.z/drivers. Perhaps Windows XP will recognize the latest one as a "better" driver than the one you have.

-Josh
Hi,
so the Driver details are as follows:

C:\WINDOWS.1\system32\DRIVERS\serenum.sys
C:\WINDOWS.1\system32\DRIVERS\serial.sys

If I look for these files I can find them but not under system32\DRIVERS there is no ""DRIVERS only "drivers". If I try to move these two files to the desktop and delete them in the original folder, they immediately reappear. I know that sounds strange but it is so.

Different question, even though this Windows XP computer has the microscope controls on them and I did want to use only a single computer for my intrinsic imaging, will the Pulse Pal work on a Windows 8 labtop? On the WIKI Pulse Pal is mentioned only up to Win7? I have already spent too much time on this and if its the old computer that is not functioning properly I do not want to waste more time on this.

Dymphie
Hi,
I tried the Pulse Pal on my Win8 labtop and it works wonderful, now I just have to figure out how to program my custom pulse train. I'll ask the question in the software forum.

Dymphie
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)