Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Connectivity issue after Arduino upload
#1
Hi, I was trying to upload a piece of code to an Arduino board. I did that through a serial connection that went through my Bpod, which in restrospect might not be the correct thing to do. The end result was that the blue indicator of the Bpod went off. I did all of the restarting and replugging I can think of but the blue indicator just won't come on again. The port still appears in PyBpod when I plugged the Bpod in but I can't run any code due to a connectivity error. Is there any way I can salvage my Bpod at this point? Thank you so much!
Reply
#2
Hi Jason,

If you sent the wrong firmware to the state machine device, you'll need to reprogram it with the correct firmware.
Since you're using PyBpod, follow the 'Manual' instructions here. To be safe, unplug all other Arduino devices from the machine during the upload.

Which device were you trying to update?

Thanks,
-Josh
Reply
#3
(02-15-2021, 06:21 PM)JasonGao Wrote: Hi Josh,

Thank you so much for replying to me. I'm using a StateMachine-Bpod2.0. I tried to upload the corresponding firmware but the compliation process in Arduino returns with an error message that I've included in the attachment. I'm trying to use the method of installing another copy of Arduino as described at the end of https://sanworks.io/forum/showthread.php?tid=230. But I'm still running into the same problem. How might I solve this problem? Thanks!



                    

(02-15-2021, 06:21 PM)JasonGao Wrote: Hi Josh,

Update: I tried copying and pasting raw codes instead of directly using the files from Github. Now my Bpod is blinking blue again! Thanks for your help!
Reply


Forum Jump: