Welcome, Guest
You have to register before you can post on our site.

Search Forums

(Advanced Search)

Forum Statistics
» Members: 27
» Latest member: CharlesYin
» Forum threads: 225
» Forum posts: 797

Full Statistics

Online Users
There are currently 10 online users.
» 1 Member(s) | 9 Guest(s)

Latest Threads
Bpod becomes slower and s...
Forum: Software
Last Post: CharlesYin
2 hours ago
» Replies: 0
» Views: 10
Serial Interface for Puls...
Forum: Software
Last Post: Jeff
3 hours ago
» Replies: 0
» Views: 3
Display visual stimulus i...
Forum: Software
Last Post: trose_neuro
02-20-2020, 10:13 AM
» Replies: 2
» Views: 67
if statement
Forum: Software
Last Post: Ilja
02-19-2020, 09:57 PM
» Replies: 3
» Views: 80
Increasing max number of ...
Forum: Software
Last Post: Josh
02-19-2020, 04:11 PM
» Replies: 1
» Views: 39
Fusion PCB Ordering Proce...
Forum: Hardware
Last Post: Max
02-19-2020, 11:45 AM
» Replies: 4
» Views: 183
Consecutive triggering of...
Forum: Software
Last Post: Josh
02-18-2020, 08:03 PM
» Replies: 1
» Views: 38
DC Barrel Jack PCB cutout
Forum: Hardware
Last Post: Josh
02-18-2020, 07:59 PM
» Replies: 1
» Views: 44
System Reboot
Forum: Software
Last Post: Josh
02-18-2020, 07:47 PM
» Replies: 1
» Views: 32
Calibrate valvemodules
Forum: Software
Last Post: Josh
02-16-2020, 02:30 AM
» Replies: 1
» Views: 38

  Unused ports stuck in ON position, or flickering back and forth
Posted by: els - 06-21-2019, 12:09 AM - Forum: Hardware - Replies (1)

The unused behavior ports on BPod State Machine r2 are either stuck in the ON position or are flickering back and forth between ON and OFF, erroneously recording hundreds of "events" per trial.  Is it best to address this via the hardware (potentially insufficient grounding of the ethernet port?), or via the software (change the state machine code to ignore Port3 and Port4)?  


  Error using trial manager object
Posted by: Noa - 06-18-2019, 11:53 AM - Forum: Software - Replies (4)

Hi josh and users,
I'm trying to run a protocol using TrialManager object, and I get one of the following two errors :

Error while evaluating TimerFcn for timer 'timer-2'

Index exceeds matrix dimensions.
Error using ArCOMObject_Bpod/read (line 348)
Error: The serial port returned 0 bytes.

Error in TrialManagerObject/startTrial (line 95)
           TrialStartTimestampBytes =, 'uint8');
Error using TrialManagerObject/startTrial (line 93)
Error: The last state machine sent was not acknowledged by the Bpod device.

It occurs when I try to run a protocol that worked OK in the past, as well as another one that is under development. 
Any idea what can be the reason? 
Anything to do with  TrialManager object's timer? 


  Pulse Pal only recognized as Bossa port, connection fails
Posted by: MJJ - 06-17-2019, 07:55 AM - Forum: Software - Replies (2)

I am trying to use Pulse Pal 2 with a windows system. When I first connected the USB cable to my PC, the Pulse Pal's display lit up, it was recognized as Arduino Due and I was able to follow the online tutorial to display the firmware version via Python. So far, so good. I then decided to switch to a Matlab interface because I did not want to have to switch between Python 3 and Python 2.7 all the time. However, with Matlab I was not able to establish serial communication with the Pulse Pal at all. At some point while I worked on the basic connection (never getting to the point of actually loading anything onto it), the Pulse Pal's display went black. It has not lit up ever since and I have not been able to establish serial communication. Now, it is recognized as a Bossa port, not an Arduino due, and every time I run the Python code that used to work, I get the following error message:

 File "C:/Users/PycharmProjects/PulsePal/", line 6, in <module>
    myPulsePal.connect('COM11') # Connect to PulsePal on port COM4 (open port, handshake and receive firmware version)
  File "C:\Users\PycharmProjects\PulsePal\", line 64, in connect
    self.firmwareVersion = struct.unpack('<I',fvBytes)[0]
struct.error: unpack requires a string argument of length 4

For reference, this is the tutorial code I am running:

from PulsePal import PulsePalObject # Import PulsePalObject
import serial

myPulsePal = PulsePalObject() 

I have tried different PCs and also uninstalling and reinstalling the driver. No change.

I do not think the Pulse Pal is completely broken because the blue lights at trigger and output channels still go off, but the display is dead and I cannot connect to it anymore. 

I would appreciate thoughts on this problem.

Question Send input action from software?
Posted by: nobias - 06-14-2019, 10:25 PM - Forum: Software - Replies (1)

Hi! Is it possible to generate an input action to the state machine from software (Matlab) on the host? I'm aware that there are softcode output actions, but is there also a way to generate an input event?

  Bpod does not turn on
Posted by: yurikadoi - 05-30-2019, 09:52 PM - Forum: Hardware - Replies (1)


I was using Bpod state machine r2.
It was working fine last month. I did not touch it for the past couple weeks and today I found it turned off (no blue or green light).

All I did today was to run windows update and install sound card on the computer. I do not remember if it was turned on or off before these procedures.

I tried plug the bpod in into multiple different computers but it does not turn on. I also changed USB and power cables but no luck.

What can I do in this case?

Thank you,

  Setup Question: Rotary Encoder and Lickometer
Posted by: Bernardo - 05-28-2019, 09:02 PM - Forum: Hardware - Replies (1)

Hi, I am currently working on setting up a lickometer and a rotary encoder at my lab. I was wondering what kind Bpod state machine is needed be able to measure the behavior recorded from the lickometer and the rotary encoder? Furthermore, we are interested in getting some sort of time measure for these behaviors as well, since they will be associate with neuron calcium imaging data. Is there anything that we will need besides the lickometer, rotary encoder, rotary encoder module, and the Bpod state machine to process the behavioral data?

  bpod not lighting on
Posted by: sandraromerop - 05-27-2019, 05:04 PM - Forum: Hardware - Replies (1)

Hi josh

any idea of why the bpod would  stop working after uploading firmware? 
this is what i did:
- bpod is connected, matlab installed, state machine (r2) firmware uploaded, and tried running a valve through one of the ports and it works
- not i tried uploading the rotary encoder module firmware, while the bpod was connected. I think i messed it up as i am not sure if the rotary encoder firmware should be uploaded to the state machine. 

Now the bpod is not even lighting on when powered. Is there a way to reset it? 


  Test curve for water
Posted by: Sarah - 05-27-2019, 12:30 AM - Forum: Software - Replies (2)

Hi, I just installed a bpod (2.0), everything seems to work fine, except for the water valve (Bpod set up using only 1 water valve and no other modules). I am not sure it uses the calibration file...
Water valve is working and delivers water, I can calibrate new values in the calibration file but if I want to test it with the test curve, I have an error message and I cannot test the valve.
Any ideas? see below the error message

"Error using BpodLiquidCalibration>RunRewardCal (line 575)
Pulse durations should be specified in seconds.

Error in BpodLiquidCalibration>RunSpecificAmount (line 808)
    Completed = RunRewardCal(nPulses, TargetValves, PulseDurations, .2);
Error while evaluating UIControl Callback."


  Starting - tutorial needed.
Posted by: globus - 05-22-2019, 10:20 PM - Forum: Software - Replies (1)

I am an 100% newbie and am trying to learn. Just got a Bpod r2 State machine and a valve. How to start from here? Any tutorial for both hardware and software?

My first goal is to control the valve to give a drop of liquid of different sizes. I have learned a little bit Arduino and have the Arduino driver installed on my computer.

Thank you!

  Need tutorial
Posted by: globus - 05-22-2019, 10:18 PM - Forum: Hardware - Replies (1)

I am an 100% newbie trying to learn. Just got a Bpod r2 State machine and a valve. How to start from here? Any tutorial both hardware and software?

My first goal is to control the valve to give a drop of liquid of different sizes.

Thank you!